Issue on iOS when Country is Ireland in adding Visa cards

I am getting this error.

any solution for it?

Thanks for help in advance.

Hi @nihal_gadhavi. Thanks for posting! Can you please verify the format of the country code you are using? The SDK states that the format should be:

Fidel.country = .ireland

Thanks,
Doug

Hi Doug,

This is an issue with the latest react native SDK. Country restricted to Ireland and scheme restricted to just Visa.

    const cardSchemes = new Set([
      Fidel.CardScheme.visa
    ]);

    country: Fidel.Country.ireland

Hello Dough,

Yes Country name is as per the above and also I tried capital letters but for all inputs, I am getting the same result.

This is other info:

React Native Environment Info:
System:
OS: macOS 10.14.6
CPU: (4) x64 Intel® Core™ i5-3210M CPU @ 2.50GHz
Memory: 226.45 MB / 8.00 GB
Shell: 3.2.57 - /bin/bash
Binaries:
Node: 12.16.2 - /usr/local/bin/node
Yarn: 1.22.4 - /usr/local/bin/yarn
npm: 6.14.4 - /usr/local/bin/npm
SDKs:
iOS SDK:
Platforms: iOS 13.2, DriverKit 19.0, macOS 10.15, tvOS 13.2, watchOS 6.1
Android SDK:
API Levels: 21, 22, 23, 24, 25, 26, 27, 28, 29
Build Tools: 28.0.3, 29.0.0, 29.0.3
IDEs:
Android Studio: 3.6 AI-192.7142.36.36.6308749
Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
npmPackages:
“react”: “16.9.0”,
“react-native”: “0.61.5”,
npmGlobalPackages:
react-native-cli: 2.0.1

Hey @Doug, any help or advice on this please? We have a lot of consumers waiting to test our app integration

Hi @gduffy - I am working on getting an update from the dev team.

1 Like

@gduffy and @nihal_gadhavi: We will have a new version of the SdK in a couple of hours to resolve this issue.

1 Like

@Doug excellent, thanks for the update

Hi @gduffy
From the development team:

The new version is now live!

Please make sure to update the iOS pods. When you reinstall the pods, it should say that you installed the latest Fidel SDK (1.6.2). You might need to update your local Cocoapods repository by running: pod repo update.