Consent text is empty

Hi guys,

I am using the Mobile SDK and I can see the consent text for the United States and Canada. But for the rest of the countries, I am getting an empty space. I am not sure if there is something else to enable in the options. Could you please help me with that?

A couple of screenshots from the example app

Thanks in advance,

Hello @cmoreno,

Could you please provide more information? It would be useful to know:

  1. What are the parameters that you set for Fidel before starting the card enrollment flow. The setup code that you have would help a lot (please be sure that you do not write the SDK Key or program ID here).
  2. Are you using the React Native SDK or the iOS SDK directly?
  3. What’s the version of the SDK that you are using?
  4. What are the languages set for your device (under Settings → General → Language & Region)? iPhone Language and the “Preferred language order”, please.

Thank you for your patience!

Hello @cornel,

Reading the questions you asked, I found out that the problem is related to the language of the device. I had it in Spanish and for this reason, the consent text was not displayed in those countries.

Thanks for your support.

Glad to know you made it work @cmoreno. We should still fix this. You might have users who have different language settings that might trigger the same bug. I tried setting my device to Spanish and it worked, so I suspect that it’s a combination of different factors that is the cause. If you can help us with these details, it will be very much appreciated. Thank you!